JED displays "Connect to the Internet..." message when displaying a video

Symptoms

When displaying a video in JED, the video cannot be played and the following message is displayed:

Windows Media Player cannot play this file. Connect to the Internet or insert the removable media on which the file is located, and then try to play the file again.

Cause

This problem occurs because Windows Media Player is getting confused about needing to connect to the Internet to view the resource, even though the resource is local and no Internet connection is required to view it.

Solution

Windows Media Player 9 and later

In Media Player 9 and later the problem can be solved by ticking the options tick box labeledConnect to the Internet (overrides other commands). This is on the Player tab of the Options screen. See also article 838101 in Microsoft's Knowledge Base.

Windows Media Player 8

Windows Media Player 8 does not have the Connect to the Internet (overrides other commands) option found in Media Player 9 and later. However if you are comfortable using regedit to set registry values directly, you can get the same effect by creating a DWORD registry value called ForceOnline in the key HKCU\Software\Microsoft\MediaPlayer\Preferences, and setting its value to 1.

Other solutions

Later versions of Windows Media Player seem less easy to confuse on this issue. Upgrading to a later version of Media Player can help.

Page date 14/02/08